Help - debug error on top of my forum

Forum rules
If you need support, please post the request in this format
[version] Description
Post Reply
jesiegel
nováček
nováček
Posts: 2
Joined: 20.1.2012 20:07:02
SmiX .MODs user: Yes

Help - debug error on top of my forum

Post by jesiegel » 20.1.2012 20:12:03

i just installed and configured the rss aggrigator, thanks so much for this. but once i configure and return to my forum i get this error on the top of my forum

[phpBB Debug] PHP Warning: in file [ROOT]/includes/mods/smixmods_feed_news_center.class.php on line 129: simplexml_load_file() [function.simplexml-load-file]: http://admin.fallensword.com/static/news.rss:249: parser error : xmlParseEntityRef: no name
[phpBB Debug] PHP Warning: in file [ROOT]/includes/mods/smixmods_feed_news_center.class.php on line 129: simplexml_load_file() [function.simplexml-load-file]: ><pubDate>Fri, 30 Dec 2011 18:12:37 +0000</pubDate></item><item><title>Santork &
[phpBB Debug] PHP Warning: in file [ROOT]/includes/mods/smixmods_feed_news_center.class.php on line 129: simplexml_load_file() [function.simplexml-load-file]: ^
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4693: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3815)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4695: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3815)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4696: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3815)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4697: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3815)


the rss feed im trying to grab is: http://admin.fallensword.com/static/news.rss i have it set to: encoding: WINDOWS-1252 type: rss

User avatar
Smix
admin
admin
Posts: 799
Joined: 16.2.2007 16:34:59
SmiX .MODs user: Yes
Location: 127.0.0.1
Contact:

Re: Help - debug error on top of my forum

Post by Smix » 25.1.2012 14:34:05

Well,
the problem itself is the feed isn't valid because uses ampersand in text, which is not correct and has to be inserted into CDATA (in the feed) ...

Code: Select all

<title>Santork & Flamedeer</title>
... because the feed is not valid, it's not working properly ... I'll check what I can do ;-)

Thanks for report
Since I´m @ work, I´m very busy ... If you like my work, please reconsider a small donation ;-)
Follow development on
github
@smixmods
Image

jesiegel
nováček
nováček
Posts: 2
Joined: 20.1.2012 20:07:02
SmiX .MODs user: Yes

Re: Help - debug error on top of my forum

Post by jesiegel » 9.2.2012 16:34:24

Smix wrote:Well,
the problem itself is the feed isn't valid because uses ampersand in text, which is not correct and has to be inserted into CDATA (in the feed) ...

Code: Select all

<title>Santork & Flamedeer</title>
... because the feed is not valid, it's not working properly ... I'll check what I can do ;-)

Thanks for report
Any update on this issue?

Clementtang
nováček
nováček
Posts: 1
Joined: 4.4.2009 22:47:28
SmiX .MODs user: Yes

Re: Help - debug error on top of my forum

Post by Clementtang » 1.12.2012 11:15:30

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/includes/mods/smixmods_feed_news_center.class.php on line 129: simplexml_load_file(): http://forums.station.sony.com/eq2/index.php?forums/game-update-notes-live.6/index.rss:4: parser error : Opening and ending tag mismatch: meta line 4 and head
[phpBB Debug] PHP Warning: in file [ROOT]/includes/mods/smixmods_feed_news_center.class.php on line 129: simplexml_load_file(): 
[phpBB Debug] PHP Warning: in file [ROOT]/includes/mods/smixmods_feed_news_center.class.php on line 129: simplexml_load_file(): ^
[phpBB Debug] PHP Warning: in file [ROOT]/includes/mods/smixmods_feed_news_center.class.php on line 129: simplexml_load_file(): http://forums.station.sony.com/eq2/index.php?forums/game-update-notes-live.6/index.rss:7: parser error : Opening and ending tag mismatch: img line 6 and div
[phpBB Debug] PHP Warning: in file [ROOT]/includes/mods/smixmods_feed_news_center.class.php on line 129: simplexml_load_file(): 
[phpBB Debug] PHP Warning: in file [ROOT]/includes/mods/smixmods_feed_news_center.class.php on line 129: simplexml_load_file(): ^
[phpBB Debug] PHP Warning: in file [ROOT]/includes/mods/smixmods_feed_news_center.class.php on line 129: simplexml_load_file(): http://forums.station.sony.com/eq2/index.php?forums/game-update-notes-live.6/index.rss:8: parser error : Opening and ending tag mismatch: div line 6 and body
[phpBB Debug] PHP Warning: in file [ROOT]/includes/mods/smixmods_feed_news_center.class.php on line 129: simplexml_load_file(): 
[phpBB Debug] PHP Warning: in file [ROOT]/includes/mods/smixmods_feed_news_center.class.php on line 129: simplexml_load_file(): ^
[phpBB Debug] PHP Warning: in file [ROOT]/includes/mods/smixmods_feed_news_center.class.php on line 129: simplexml_load_file(): http://forums.station.sony.com/eq2/index.php?forums/game-update-notes-live.6/index.rss:9: parser error : Opening and ending tag mismatch: body line 5 and html
[phpBB Debug] PHP Warning: in file [ROOT]/includes/mods/smixmods_feed_news_center.class.php on line 129: simplexml_load_file(): 
[phpBB Debug] PHP Warning: in file [ROOT]/includes/mods/smixmods_feed_news_center.class.php on line 129: simplexml_load_file(): ^
[phpBB Debug] PHP Warning: in file [ROOT]/includes/mods/smixmods_feed_news_center.class.php on line 129: simplexml_load_file(): http://forums.station.sony.com/eq2/index.php?forums/game-update-notes-live.6/index.rss:10: parser error : Premature end of data in tag head line 2
[phpBB Debug] PHP Warning: in file [ROOT]/includes/mods/smixmods_feed_news_center.class.php on line 129: simplexml_load_file(): 
[phpBB Debug] PHP Warning: in file [ROOT]/includes/mods/smixmods_feed_news_center.class.php on line 129: simplexml_load_file(): ^
[phpBB Debug] PHP Warning: in file [ROOT]/includes/mods/smixmods_feed_news_center.class.php on line 129: simplexml_load_file(): http://forums.station.sony.com/eq2/index.php?forums/game-update-notes-live.6/index.rss:10: parser error : Premature end of data in tag html line 1
[phpBB Debug] PHP Warning: in file [ROOT]/includes/mods/smixmods_feed_news_center.class.php on line 129: simplexml_load_file(): 
[phpBB Debug] PHP Warning: in file [ROOT]/includes/mods/smixmods_feed_news_center.class.php on line 129: simplexml_load_file(): ^
Same Here

User avatar
Smix
admin
admin
Posts: 799
Joined: 16.2.2007 16:34:59
SmiX .MODs user: Yes
Location: 127.0.0.1
Contact:

Re: Help - debug error on top of my forum

Post by Smix » 20.1.2013 16:51:56

Hello,
I still dont have any new info about it ...
Since I´m @ work, I´m very busy ... If you like my work, please reconsider a small donation ;-)
Follow development on
github
@smixmods
Image

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest